Nginx + PHP-FPM : installer les dernières versions sur Ubuntu

2

Posted by florian | Posted in Geekisme, Logiciels Libres, Sysadmin | Posted on 19-06-2011

Mots-clés : , , ,

Ami internaute, si ton serveur est sous Ubuntu et que :
- soit on se moque de la version de ton Nginx ou de ton PHP-FPM
- soit tu es complexé par la version vieillissante de ton Nginx
- soit tu es complexé par les cheveux blancs de ton PHP-FPM
- soit un peu tout ça à la fois

Alors tu es au bon endroit : voilà comment tu vas pouvoir garder tes Nginx et PHP-FPM “up-to-date” avec un minimum d’efforts, cela va sans dire…

Voici comment faire, en 3 étapes seulement !
Lire la suite »

Downgrader PHP de 5.3.2 à 5.2.10 sur Ubuntu 10.04 “Lucid” LTS

5

Posted by florian | Posted in Logiciels Libres | Posted on 10-06-2010

Mots-clés : , , , , ,

Alors oui, Ubuntu est récemment sortie dans sa version 10.04 LTS, c’est super, on a tous sautillé de joie.

Problème : quand on est un drupaler de la première heure et qu’on maintient encore des sites sous Drupal 5 (pas toujours possible d’upgrader en 6 stable), on risque de cumuler les infortunes avec la version 5.3 de PHP que cette nouvelle mouture de notre distrib préférée nous apporte.

En pareil cas, la seule solution qui tienne la route est malheureusement de downgrader en version 5.2…

Hep ! Ne pars pas ! Ce n’est pas si compliqué !

Lire la suite »

Drupal, PHP et les hooks SVN

0

Posted by florian | Posted in Logiciels Libres | Posted on 12-03-2009

Mots-clés : , , ,

((/public/news/drupal_logo.png|drupal_logo.png|L|Drupal PHP hooks Subversion SVN)) Tout développeur ([PHP|http://www.php.net] ou pas) normalement constitué –a recours– devrait recourir à l’utilisation de [Subversion|http://subversion.tigris.org] pour gérer les versions de ses applications, faciliter le travail en équipe ou encore mettre en oeuvre des processus de déploiements automatisés. Or, quel développeur n’a jamais publié un code contenant une erreur de syntaxe ?%%% Quel développeur n’a jamais fait un commit “barbare”, sans aucun commentaire ?%%% Quel développeur n’aurait pas aimé être prévenu d’un commit pour éviter un conflit SVN ?
Lire la suite »